支撑压力主图指标(附公式源码)

藏家903 关注

收藏于 : 2021-08-23 18:31   被转藏 : 14       转藏到我的文章库

这虽然只是一个参考的技术理解,但是也可以对于个人的技术有所提高,参考一下。

上方有顶部压力线,下方是底部支撑线。

带有点点的这种线条,是股价阶段的高点,也可以判断是一个压力区间的划线。

跌破底部支撑线之后,股价会有一个下行,这是我卖出可以少损失。

以下,这是一个波段区间的,箱体运作图例。

如果在一个箱体区间运动,波动向下,可以参考买卖点的提示。下面是源码,这是一个主图的技术类指标。

主图指标公式:

LC:=REF(CLOSE,1);

RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);

TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);

HA:=(HIGH - REF(HIGH,1));

LA:=(REF(LOW,1) - LOW);

DMP:=SUM(IF(((HA > 0) AND (HA > LA)),HA,0),10);

DMM:=SUM(IF(((LA > 0) AND (LA > HA)),LA,0),10);

PDI:=((DMP * 100) / TR1);

MDI:=((DMM * 100) / TR1);

ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);

AV:=(RSI5 + ADX);

DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);

WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));

NEWVOL:=(RSI5 - WR10);

买:=(AV + NEWVOL);

卖:=(AV - NEWVOL);

DRAWTEXT(CROSS(买,卖),L*0.98,'买'),COLORYELLOW;

DRAWTEXT(CROSS(卖,买),H*1.02,'卖'),COLORGREEN;

MA1:=MA(CLOSE,3);

MA2:=MA(CLOSE,5);

X:=BARSLAST(CROSS(MA1,MA2));

止损:REF(C,X+1)*(1-0.05),COLORGREEN;

止赢:REF(IF(C>O,C,O),X)*(1+0.1),COLORRED;

回踩止赢:HHV(H,X+1)*(1-0.03),COLORYELLOW,POINTDOT,LINETHICK4;

用法:最好是配合均线系统,比如60日均线向上的情况下,出现买入机会就参考,60日均线向下的机会谨慎对待;箱体短周期波动,可以结合一下macd和kdj,或者是主力吸筹之类的技术指标组合使用。

文章点评
相关文章
藏家903 关注

文章收藏:1

TA的最新收藏
藏友最新收藏
好网角移动端
好网角APP
手机一键收藏