通达信最准备指标分享——做T神器、准确买-卖点、私募利器指标!

藏家367

收藏于 : 2019-12-15 08:09   被转藏 : 41       转藏到我的文章库

 最近一直没有给大家发什么指标,实在是太忙了,今天用一天时间做了几个,配合使用是比较好的,大家觉得那个好用就自己复制。很多时候不是我不发源码,有时候发过去你们说测试错误,导出去文档这里又发不出。所以我希望我们互相理解。好东西我会第一时间在这里分享!这个是总的图!

第一、这个是主图指标,有比较清晰的买卖点提示,我一直用的是缠论,感觉这个比较清晰吧,大家看看有什么不明白的可以在评论去说出来。

VAR3:=LLV(HIGH,240);

VAR4:=100*(CLOSE-VAR3)/VAR3;

VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;

VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;

VAR7:=0;

VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;

VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;

VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);

VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);

VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);

VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);

VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);

VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);

VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);

VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);

VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);

VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);

买1:=VAR10;

买2:=(VAR11+VAR13+VAR15+VAR17);

卖1:=(VAR12+VAR14+VAR16+VAR18);

买点:IF(买1>0 OR 买2>0,LOW*0.99,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW;

DRAWTEXT(买1>0 OR 买2>0,LOW*0.99,'买入'),COLORYELLOW;

卖点:IF(卖1>0,HIGH*1.01,DRAWNULL),CROSSDOT,LINETHICK3,COLORGREEN;

DRAWTEXT(卖1>0,HIGH*1.02,'卖出'),COLORGREEN;

第二、做T神器 ,这个是配合主图使用的,因为毕竟一个指标是不准确的,配合使用是比较好的。感觉好用的自己复制。

DRAWGBK(C>0, RGB(50,60,250),RGB(17,21,89),0,'11',0);

H1:=MAX(DYNAINFO(3),DYNAINFO(5));

L1:=MIN(DYNAINFO(3),DYNAINFO(6));

P1:=H1-L1;

阻力:=L1+P1*7/8,COLORGREEN;

支撑:=L1+P1*0.5/8,COLORRED;

中线:=(支撑+阻力)/2,COLORWHITE,POINTDOT;

V11:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);

趋势线:EMA(V11,3),LINETHICK2,COLORLIMAGENTA;

V12:=(趋势线-REF(趋势线,1))/REF(趋势线,1)*100;

准备买入:STICKLINE(趋势线<11,趋势线,11,5,0),COLORYELLOW;

AA:=(趋势线<11) AND FILTER((趋势线<=11),15) AND C<中线;

BB0:=REF(趋势线,1)<11 AND CROSS(趋势线,11) AND C<中线;

BB1:=REF(趋势线,1)<11 AND REF(趋势线,1)>6 AND CROSS(趋势线,11);

BB2:=REF(趋势线,1)<6 AND REF(趋势线,1)>3 AND CROSS(趋势线,6);

BB3:=REF(趋势线,1)<3 AND REF(趋势线,1)>1 AND CROSS(趋势线,3);

BB4:=REF(趋势线,1)<1 AND REF(趋势线,1)>0 AND CROSS(趋势线,1);

BB5:=REF(趋势线,1)<0 AND CROSS(趋势线,0);

BB:=BB1=1 OR BB2=1 OR BB3=1 OR BB4=1 OR BB5=1;

下单买入:STICKLINE(BB=1 AND C<中线,11,50,3,0),COLORRED;

DRAWICON(BB=1 AND C<中线,55,1);

DRAWTEXT(BB0,60,'★买'),COLORRED;

DRAWTEXT(AA,16,'准备买入'),COLORYELLOW;

准备卖出:STICKLINE(趋势线>89,趋势线,89,5,0),COLORWHITE;

CC:=(趋势线>89) AND FILTER((趋势线>89),15) AND C>中线;

DD0:=REF(趋势线,1)>89 AND CROSS(89,趋势线) AND C>中线;

DD1:=REF(趋势线,1)>89 AND REF(趋势线,1)<94 AND CROSS(89,趋势线);

DD2:=REF(趋势线,1)>94 AND REF(趋势线,1)<97 AND CROSS(94,趋势线);

DD3:=REF(趋势线,1)>97 AND REF(趋势线,1)>99 AND CROSS(97,趋势线);

DD4:=REF(趋势线,1)>99 AND REF(趋势线,1)<100 AND CROSS(99,趋势线);

DD5:=REF(趋势线,1)>100 AND CROSS(100,趋势线);

DD:=DD1=1 OR DD2=1 OR DD3=1 OR DD4=1 OR DD5=1;

下单卖出:STICKLINE(DD=1 AND C>中线,89,50,3,0),COLORGREEN;

DRAWICON(DD=1 AND C>中线,45,2);

DRAWTEXT(DD0,40,'★卖'),COLORGREEN;

DRAWTEXT (CC,84,'准备卖出'),COLORWHITE;

顶:89,COLORGREEN;

底:11,COLORRED;

中:50,POINTDOT,COLORWHITE;

DRAWTEXT(ISLASTBAR,顶,'顶'),COLORGREEN;

DRAWTEXT(ISLASTBAR,底,'底'),COLORRED;

DRAWTEXT(ISLASTBAR,中,'中'),COLORWHITE;

今天就先分享这么多,大家还有什么问题可以在评论区说出来或者私聊,看到后我会及时回复!好的东西我都会拿出来分享,之前缠论大家不清楚的地方我回头总结一下,在写出来我们一起讨论!

文章点评
  • 藏家367 藏主
    1楼 2019-12-15 08:09

    藏家367 已转藏

相关文章
藏友最新收藏
好网角移动端
好网角APP
手机一键收藏