史上最牛MACD指标公式(源码附图)

青灯古城

收藏于 : 2020-10-15 04:08   被转藏 : 12       转藏到我的文章库

DIFF:EMA(CLOSE,6)-EMA(CLOSE,16),ColorFFFF26;
 DEA:EMA(DIFF,5),Color8A15FF;
 MACD:=2*(DIFF-DEA);
 对DIFF :0-(EMA(CLOSE,6) - EMA(CLOSE,16));
 对DEA :0-(EMA(DIFF,5));
 对称 : 0-(2*(DIFF-DEA)),STICK,ColorFF6060,LINETHICK1;
 {D1:EMA(C,16)-EMA(C,6),Color26FF26;
 E2:EMA(D1,5),ColorFF1EFF;};
 STICKLINE(MACD>=0,MACD,0,4,1),COLORF00FF0;
 STICKLINE(MACD<0,MACD,0,4,1),colorwhite;
 STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,10,0 ),Color00C4C4;
 STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,6.3,0 ),Color00EAEA;
 STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,2.2,0 ),Color0BFFFF;
 STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,1.65,0 ),Color46FFFF;
 STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,8 ,0 ),Color0000BB;
 STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,6.3 ,0 ),Color0000F0;
 STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,2.2,0 ),Color1111FF;
 STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1.65 ,0 ),Color3535FF;
 STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,10,0 ),Color9B009B;
 STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,6.3 ,0 ),ColorCA00CA;
 STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,2.2,0 ),ColorF000F0;
 STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1.65,0 ),ColorFF28FF;
 STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,8,0 ),Color00AA00;
 STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,6.3 ,0 ),Color00CE00;
 STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,2.2,0 ),Color00F700;
 STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,1.65 ,0 ),Color2DFF2D;
 低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
 STICKLINE(低位金叉,0,-0.18,10,0),ColorE8E8E8;
 STICKLINE(低位金叉,0,-0.18,4,0),ColorF2F2F2;
 STICKLINE(低位金叉,0,-0.18,2,0),ColorFFFFFF;
 DRAWTEXT(低位金叉,-0.2,' 金叉'),ColorFFFFFF;
 JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
 二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
 STICKLINE(二次金叉,0,-0.18,10,0),Color0042CC;
 STICKLINE(二次金叉,0,-0.18,8,0),Color004FF2;
 STICKLINE(二次金叉,0,-0.18,8,0),Color3375FF;
 DRAWTEXT(二次金叉,-0.2,' 金叉二'),Color3375FF;
 A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
 底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
 STICKLINE(底背离,0,0.13,10,0),ColorCECE00;
 STICKLINE(底背离,0,0.13,4,0),ColorFFFF00;
 STICKLINE(底背离,0,0.13,2,0),ColorFFFF44;
 DRAWLINE(A1=0,DEA,底背离,DEA,0),ColorFFFFFF,linethick1;
 DRAWTEXT(底背离,0.3,' 底背离'),ColorFFFF26;
 A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
 顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
 DRAWLINE(A2=0,DEA,顶背离,DEA,0),colorgreen,linethick1;
 

文章点评
  • 青灯古城 藏主
    1楼 2020-10-15 04:08

    青灯古城 已转藏

相关文章
藏友最新收藏
好网角移动端
好网角APP
手机一键收藏