• 阻击疯牛--主图(源码 主图 贴图)  

    GJ:=(C+H+L+O)/4;
    明日阻力:=L+(GJ-L)+(C-L);
    明日支撑:=L+(C-GJ);
    下档线:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
    RRRSV:=SMA(下档线,3,1);
    KKK:=SMA(RRRSV,3,1);
    DDDDD:=((3 * RRRSV) - (2 * KKK));
    JJ12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
    RSV24:=SMA(JJ12,3,1);
    K24:=SMA(RSV24,3,1);
    D24:=((3 * RSV24) - (2 * K24));
    压力2:=IF(CROSS(D24,DDDDD),HIGH,REF(HIGH,BARSLAST(CROSS(D24,DDDDD)))),COLORFFFFFF;
    底部:=LLV(HIGH,30),COLOR00FF00;
    今日阻力:REF(明日阻力 , 1),NODRAW;
    今日支撑:REF(明日支撑 , 1),NODRAW;
    压力位:IF(ISLASTBAR,压力2,DRAWNULL),NODRAW;
    底部位:IF(ISLASTBAR,底部,DRAWNULL),NODRAW;
    高:=REF(HHV(H,80),3);
    低:=REF(LLV(L,80),3);
    H19:=高-(高-低)*0.191;
    H38:=高-(高-低)*0.382;
    H中:=高-(高-低)*0.5;
    H61:=高-(高-低)*0.618;
    H80:=高-(高-低)*0.809;
    顶点:REFDATE(高,DATE),POINTDOT,COLORWHITE;
    疯牛19.8:REFDATE(H19,DATE),POINTDOT,COLORYELLOW;
    突破38.2:REFDATE(H38,DATE),POINTDOT,COLORMAGENTA;
    平衡50:REFDATE(H中,DATE),POINTDOT,COLORRED;
    回落61.8:REFDATE(H61,DATE),POINTDOT,COLORGREEN;
    安全80.9:REFDATE(H80,DATE),POINTDOT,COLORBLUE;
    低点:REFDATE(低,DATE),POINTDOT,COLORWHITE;
    DRAWTEXT(ISLASTBAR,顶点,'顶点'),COLORWHITE;
    DRAWTEXT(ISLASTBAR,疯牛19.8,'疯牛'),COLORYELLOW;
    DRAWTEXT(ISLASTBAR,突破38.2,'突破'),COLORMAGENTA;
    DRAWTEXT(ISLASTBAR,平衡50,'平衡'),COLORRED;
    DRAWTEXT(ISLASTBAR,回落61.8,'回落'),COLORMAGENTA;
    {DRAWTEXT(ISLASTBAR,安全80.9,'安全'),COLORYELLOW;
    DRAWTEXT(ISLASTBAR,低点,'低点'),COLORWHITE};
    VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
    VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
    VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
    VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
    VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
    VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
    VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
    VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
    VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
    VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
    VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
    VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
    VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
    VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
    VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
    VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
    VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
    VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
    VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
    VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
    VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
    VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
    VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
    VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
    VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
    DRAWICON(VAR19,L*0.98,1);
    DRAWICON(CROSS(LLV(AMOUNT/V/100,3),L) AND V>REF(V,3) AND C<O,O*1.1,2);
    MA6:EMA(C,6),COLORWHITE;
    MA18:EMA(C,18),COLORGREEN;
    骑:STICKLINE(MA6>MA18 AND MA6>=REF(MA6,1) AND MA18>REF(MA18,1),MA6,MA18,0.3,0),COLORRED;
    疯:STICKLINE(MA6>MA18 AND MA6<REF(MA6,1) AND MA18>=REF(MA18,1),MA6,MA18,0.3,0),COLORYELLOW;
    牛:STICKLINE(MA6<MA18 AND MA6<=REF(MA6,1) AND MA18<REF(MA18,1),MA6,MA18,0.3,0),COLORGREEN;
    中:STICKLINE(MA6<MA18 AND MA6>REF(MA6,1) AND MA18<=REF(MA18,1),MA6,MA18,0.3,0),COLORCYAN;
    长:STICKLINE(MA6>MA18 AND MA6>REF(MA6,1) AND MA18<=REF(MA18,1),MA6,MA18,0.3,0),COLORMAGENTA;
    线:STICKLINE(MA6<MA18 AND MA6<REF(MA6,1) AND MA18>=REF(MA18,1),MA6,MA18,0.3,0),COLORBLUE;
    买进:=CROSS(MA6,MA18) AND MA18>=REF(MA18,1);
    DRAWICON(买进,L*0.95,9);
    DRAWTEXT(CROSS(85,RSI),(HIGH * 1.02),'落袋'),COLORCYAN;
     

    特别重申:本篇文档资料为 “好网角收藏夹” 注册用户(收藏家)上传共享,仅供参考之用,请谨慎辨别,不代表本站任何观点。
    好网角收藏夹为网友提供资料整理云存储服务,仅提供信息存储共享平台。
    不良信息删除、涉嫌侵权举报邮箱:dongye2016@qq.com。

    相关文章

     

    最新文章

    更多 >>

    TOP